ShopSite Pro v5 -- Custom Templates Help

This is an archive of old posting to the User Forum

ShopSite Pro v5 -- Custom Templates Help

Postby Cheryl » Wed Jul 25, 2001 4:18 pm

Hi --

I'm trying to create a custom Product template so that I can use it
instead of the templates that come built-in with ShopSite Pro
(Mondrian, Matte, Lefty, etc.).

According to the ShopSite documentation, all I have to do is create an
HTML page like usual and throw in some ShopSite custom template tags.
Like...

[-- HEADER --]
[-- FOOTER --]
[-- LOOP x --]
[-- END_LOOP x --]

.... just to name a few.

So, I created a page, and uploaded it to my data/templates/pages
directory according to the instructions. I, then, went back into
ShopSite to choose a product to apply my new page template to. However,
my template was not listed in the pull-down menu.

I've cleared my cache, deleted my cookies file, hit SHIFT+RELOAD in my
web browser but to no avail.

Shouldn't the custom page and product template show up immediately after
I've FTP'ed it to the server? Does the server have to be restarted in
order for it to appear? Does it take awhile? I would think this is
instantaneous. Do I have to log in and out of ShopSite?

My ISP is Bizland.com and I'm not sure they have anyone knowledgeable
about ShopSite.

What am I doing wrong?

Thanks,
Cheryl
Cheryl
 

Re: ShopSite Pro v5 -- Custom Templates Help

Postby loren_d_c » Wed Jul 25, 2001 5:15 pm

You either don't have the templates directory in the correct data
directory (the 'templates' directory should be in the same directory as
files like order.db and pages.db and products.db) or the directories
and/or template files you created don't have the correct permissions to
be read by the webserver. I am sure that if you point someone at BizLand
in that direction they could figure it out.

-Loren




Cheryl wrote:
Hi --

I'm trying to create a custom Product template so that I can use it
instead of the templates that come built-in with ShopSite Pro
(Mondrian, Matte, Lefty, etc.).

According to the ShopSite documentation, all I have to do is create an
HTML page like usual and throw in some ShopSite custom template tags.
Like...

[-- HEADER --]
[-- FOOTER --]
[-- LOOP x --]
[-- END_LOOP x --]

... just to name a few.

So, I created a page, and uploaded it to my data/templates/pages
directory according to the instructions. I, then, went back into
ShopSite to choose a product to apply my new page template to. However,
my template was not listed in the pull-down menu.

I've cleared my cache, deleted my cookies file, hit SHIFT+RELOAD in my
web browser but to no avail.

Shouldn't the custom page and product template show up immediately after
I've FTP'ed it to the server? Does the server have to be restarted in
order for it to appear? Does it take awhile? I would think this is
instantaneous. Do I have to log in and out of ShopSite?

My ISP is Bizland.com and I'm not sure they have anyone knowledgeable
about ShopSite.

What am I doing wrong?

Thanks,
Cheryl
loren_d_c
 
Posts: 2308
Joined: Fri Aug 04, 2006 12:02 pm
Location: Anywhere

Re: ShopSite Pro v5 -- Custom Templates Help

Postby Guest » Wed Jul 25, 2001 7:54 pm

Cheryl:
as Loren pointed out, make sure you see all other ShopSite templates in the
directory - then you know they are stored in the right place. Our host has
the template directory under cgi-bin/bo/templates - but this may vary in
your case.

Joachim

Cheryl wrote:

Hi --

I'm trying to create a custom Product template so that I can use it
instead of the templates that come built-in with ShopSite Pro
(Mondrian, Matte, Lefty, etc.).

According to the ShopSite documentation, all I have to do is create an
HTML page like usual and throw in some ShopSite custom template tags.
Like...

[-- HEADER --]
[-- FOOTER --]
[-- LOOP x --]
[-- END_LOOP x --]

... just to name a few.

So, I created a page, and uploaded it to my data/templates/pages
directory according to the instructions. I, then, went back into
ShopSite to choose a product to apply my new page template to. However,
my template was not listed in the pull-down menu.

I've cleared my cache, deleted my cookies file, hit SHIFT+RELOAD in my
web browser but to no avail.

Shouldn't the custom page and product template show up immediately after
I've FTP'ed it to the server? Does the server have to be restarted in
order for it to appear? Does it take awhile? I would think this is
instantaneous. Do I have to log in and out of ShopSite?

My ISP is Bizland.com and I'm not sure they have anyone knowledgeable
about ShopSite.

What am I doing wrong?

Thanks,
Cheryl
Guest
 

Re: ShopSite Pro v5 -- Custom Templates Help

Postby Katrina Morris » Thu Jul 26, 2001 7:56 am

Hi Cheryl,

I was a bit confused when I first started using custom templates, but once
you get started, they're fantastic. They really give you alot of control.

I think also where you've gone wrong is that you created a normal HTML page
and inserted tags. This will not work. There are other defining tags that
you will need outside the <html> brackets. Make sure you go back and read
the help section on custom templates very carefully. Also, look at the
sample custom templates for pages and products. This will be a great
springboard for you to use. After I read the instructions over two or three
times, it was a breeze.

Hope this helps,

Katrina
http://www.rexart.com

"Cheryl" <cgalvez@bluegrottomedia.com> wrote in message
news:3B5F53D2.7A2AA79F@bluegrottomedia.com...
Hi --

I'm trying to create a custom Product template so that I can use it
instead of the templates that come built-in with ShopSite Pro
(Mondrian, Matte, Lefty, etc.).

According to the ShopSite documentation, all I have to do is create an
HTML page like usual and throw in some ShopSite custom template tags.
Like...

[-- HEADER --]
[-- FOOTER --]
[-- LOOP x --]
[-- END_LOOP x --]

... just to name a few.

So, I created a page, and uploaded it to my data/templates/pages
directory according to the instructions. I, then, went back into
ShopSite to choose a product to apply my new page template to. However,
my template was not listed in the pull-down menu.

I've cleared my cache, deleted my cookies file, hit SHIFT+RELOAD in my
web browser but to no avail.

Shouldn't the custom page and product template show up immediately after
I've FTP'ed it to the server? Does the server have to be restarted in
order for it to appear? Does it take awhile? I would think this is
instantaneous. Do I have to log in and out of ShopSite?

My ISP is Bizland.com and I'm not sure they have anyone knowledgeable
about ShopSite.

What am I doing wrong?

Thanks,
Cheryl
Katrina Morris
 

Re: ShopSite Pro v5 -- Custom Templates Help

Postby Cheryl » Fri Jul 27, 2001 10:32 pm

Hi!

Thanks for the advice everyone! Based on Loren's tip, Bizland.com was able to
determine that I was FTP'ing my custom templates to the wrong directory. It
didn't help that they never informed me where to put it in the first place.
But, anyway, all is OK and I am knee-deep in customizing page and product
templates. :)

Question. I'm creating a simple custom page that will loop through all the
products that I want displayed on this particular page. Easy enough if I want
to display each product one after the other all the way down the page. But, I
want to display 2 products per row all the way down the page. Now, it can
easily be done using the built-in templates. You just choose the 2-column
attribute when editing the built-in page's layout. But, when you're doing
custom page templates, how do you tell ShopSite to essentially read two products
at a time, placing the first product info in table cell 1 and then the second
product info in table cell 2? Then, close out the table row and pull another 2
products and display them side-by-side in the second row. I hope I'm making
sense here. :)

Any suggestions?!

Cheryl
www.blissweddingsmarket.com


Katrina Morris wrote:

Hi Cheryl,

I was a bit confused when I first started using custom templates, but once
you get started, they're fantastic. They really give you alot of control.

I think also where you've gone wrong is that you created a normal HTML page
and inserted tags. This will not work. There are other defining tags that
you will need outside the <html> brackets. Make sure you go back and read
the help section on custom templates very carefully. Also, look at the
sample custom templates for pages and products. This will be a great
springboard for you to use. After I read the instructions over two or three
times, it was a breeze.

Hope this helps,

Katrina
http://www.rexart.com

"Cheryl" <cgalvez@bluegrottomedia.com> wrote in message
news:3B5F53D2.7A2AA79F@bluegrottomedia.com...

Hi --

I'm trying to create a custom Product template so that I can use it
instead of the templates that come built-in with ShopSite Pro
(Mondrian, Matte, Lefty, etc.).

According to the ShopSite documentation, all I have to do is create an
HTML page like usual and throw in some ShopSite custom template tags.
Like...

[-- HEADER --]
[-- FOOTER --]
[-- LOOP x --]
[-- END_LOOP x --]

... just to name a few.

So, I created a page, and uploaded it to my data/templates/pages
directory according to the instructions. I, then, went back into
ShopSite to choose a product to apply my new page template to. However,
my template was not listed in the pull-down menu.

I've cleared my cache, deleted my cookies file, hit SHIFT+RELOAD in my
web browser but to no avail.

Shouldn't the custom page and product template show up immediately after
I've FTP'ed it to the server? Does the server have to be restarted in
order for it to appear? Does it take awhile? I would think this is
instantaneous. Do I have to log in and out of ShopSite?

My ISP is Bizland.com and I'm not sure they have anyone knowledgeable
about ShopSite.

What am I doing wrong?

Thanks,
Cheryl
Cheryl
 

Re: ShopSite Pro v5 -- Custom Templates Help

Postby Barney Stone » Sat Jul 28, 2001 7:28 am

Cheryl -

You might want to check out our ECom Assembler for ShopSite at
http://stoneedge.com/ecomassembler.htm

The ECom Assembler gives you much more control over your pages, including
multiple columns, cross-sell items, bulleted feature lists, and much more.

Feel free to call me if you have any questions about it.

- Barney Stone, President
Stone Edge Technologies, Inc.
www.ShopSiteUtilities.com
215-641-1837



"Cheryl" <cgalvez@bluegrottomedia.com> wrote in message
news:3B624E87.A78BAA24@bluegrottomedia.com...
Hi!

Thanks for the advice everyone! Based on Loren's tip, Bizland.com was
able to
determine that I was FTP'ing my custom templates to the wrong directory.
It
didn't help that they never informed me where to put it in the first
place.
But, anyway, all is OK and I am knee-deep in customizing page and product
templates. :)

Question. I'm creating a simple custom page that will loop through all
the
products that I want displayed on this particular page. Easy enough if I
want
to display each product one after the other all the way down the page.
But, I
want to display 2 products per row all the way down the page. Now, it can
easily be done using the built-in templates. You just choose the 2-column
attribute when editing the built-in page's layout. But, when you're doing
custom page templates, how do you tell ShopSite to essentially read two
products
at a time, placing the first product info in table cell 1 and then the
second
product info in table cell 2? Then, close out the table row and pull
another 2
products and display them side-by-side in the second row. I hope I'm
making
sense here. :)

Any suggestions?!

Cheryl
www.blissweddingsmarket.com


Katrina Morris wrote:

Hi Cheryl,

I was a bit confused when I first started using custom templates, but
once
you get started, they're fantastic. They really give you alot of
control.

I think also where you've gone wrong is that you created a normal HTML
page
and inserted tags. This will not work. There are other defining tags
that
you will need outside the <html> brackets. Make sure you go back and
read
the help section on custom templates very carefully. Also, look at the
sample custom templates for pages and products. This will be a great
springboard for you to use. After I read the instructions over two or
three
times, it was a breeze.

Hope this helps,

Katrina
http://www.rexart.com

"Cheryl" <cgalvez@bluegrottomedia.com> wrote in message
news:3B5F53D2.7A2AA79F@bluegrottomedia.com...

Hi --

I'm trying to create a custom Product template so that I can use it
instead of the templates that come built-in with ShopSite Pro
(Mondrian, Matte, Lefty, etc.).

According to the ShopSite documentation, all I have to do is create an
HTML page like usual and throw in some ShopSite custom template tags.
Like...

[-- HEADER --]
[-- FOOTER --]
[-- LOOP x --]
[-- END_LOOP x --]

... just to name a few.

So, I created a page, and uploaded it to my data/templates/pages
directory according to the instructions. I, then, went back into
ShopSite to choose a product to apply my new page template to.
However,
my template was not listed in the pull-down menu.

I've cleared my cache, deleted my cookies file, hit SHIFT+RELOAD in my
web browser but to no avail.

Shouldn't the custom page and product template show up immediately
after
I've FTP'ed it to the server? Does the server have to be restarted in
order for it to appear? Does it take awhile? I would think this is
instantaneous. Do I have to log in and out of ShopSite?

My ISP is Bizland.com and I'm not sure they have anyone knowledgeable
about ShopSite.

What am I doing wrong?

Thanks,
Cheryl

Barney Stone
 

Re: ShopSite Pro v5 -- Custom Templates Help

Postby Guest » Thu Aug 09, 2001 6:43 pm

Hi Cheryl:
this is currently not possible in ShopSite 5.x (unless, as you pointed out, use the
built-in templates). But, if I am not mistaken, it will be a feature of the next
release of ShopSite. So, stay tuned!

Joachim


Cheryl wrote:

Hi!

Thanks for the advice everyone! Based on Loren's tip, Bizland.com was able to
determine that I was FTP'ing my custom templates to the wrong directory. It
didn't help that they never informed me where to put it in the first place.
But, anyway, all is OK and I am knee-deep in customizing page and product
templates. :)

Question. I'm creating a simple custom page that will loop through all the
products that I want displayed on this particular page. Easy enough if I want
to display each product one after the other all the way down the page. But, I
want to display 2 products per row all the way down the page. Now, it can
easily be done using the built-in templates. You just choose the 2-column
attribute when editing the built-in page's layout. But, when you're doing
custom page templates, how do you tell ShopSite to essentially read two products
at a time, placing the first product info in table cell 1 and then the second
product info in table cell 2? Then, close out the table row and pull another 2
products and display them side-by-side in the second row. I hope I'm making
sense here. :)

Any suggestions?!

Cheryl
www.blissweddingsmarket.com

Katrina Morris wrote:

Hi Cheryl,

I was a bit confused when I first started using custom templates, but once
you get started, they're fantastic. They really give you alot of control.

I think also where you've gone wrong is that you created a normal HTML page
and inserted tags. This will not work. There are other defining tags that
you will need outside the <html> brackets. Make sure you go back and read
the help section on custom templates very carefully. Also, look at the
sample custom templates for pages and products. This will be a great
springboard for you to use. After I read the instructions over two or three
times, it was a breeze.

Hope this helps,

Katrina
http://www.rexart.com

"Cheryl" <cgalvez@bluegrottomedia.com> wrote in message
news:3B5F53D2.7A2AA79F@bluegrottomedia.com...

Hi --

I'm trying to create a custom Product template so that I can use it
instead of the templates that come built-in with ShopSite Pro
(Mondrian, Matte, Lefty, etc.).

According to the ShopSite documentation, all I have to do is create an
HTML page like usual and throw in some ShopSite custom template tags.
Like...

[-- HEADER --]
[-- FOOTER --]
[-- LOOP x --]
[-- END_LOOP x --]

... just to name a few.

So, I created a page, and uploaded it to my data/templates/pages
directory according to the instructions. I, then, went back into
ShopSite to choose a product to apply my new page template to. However,
my template was not listed in the pull-down menu.

I've cleared my cache, deleted my cookies file, hit SHIFT+RELOAD in my
web browser but to no avail.

Shouldn't the custom page and product template show up immediately after
I've FTP'ed it to the server? Does the server have to be restarted in
order for it to appear? Does it take awhile? I would think this is
instantaneous. Do I have to log in and out of ShopSite?

My ISP is Bizland.com and I'm not sure they have anyone knowledgeable
about ShopSite.

What am I doing wrong?

Thanks,
Cheryl
Guest
 


Return to User Forum Archive

Who is online

Users browsing this forum: No registered users and 1 guest