IE error: "An error occurred in the secure channel support"
When placing a test order with Internet Explorer, you get the following error message when the cart tries to go secure:
Internet Explorer cannot open the Internet site https://
An error occurred in the secure channel support
Solution ID: S03118
The following is Microsoft's description of the problem, found at:
http://support.microsoft.com/support/kb/articles/q198/9/70.asp
SYMPTOMS
When you try to connect to a secure Web site, you may receive the following error message:
Internet Explorer cannot open the Internet site https://
An error occurred in the secure channel support
CAUSE
This error message can occur if the server uses a certificate with a nonstandard length. The nonstandard length results in a
nonstandard public key length, which Internet Explorer does not support. Internet Explorer supports only public keys with
standard lengths (such as 512 bits, 1024 bits, 2048 bits, and so on).
RESOLUTION
To be compatible with Internet Explorer, the site using the nonstandard public key length should generate a new certificate
request using a standard length (such as 512, 1024, or 2048 bits). The site then needs to obtain a new corresponding
certificate.
As a possible workaround, re-register the Rsabase.dll file by clicking Start, clicking Run, typing "regsvr32 rsabase.dll"
(without the quotation marks) in the Open box, and then clicking OK.
Related Articles
No related articles were found.
Attachments
No attachments were found.
Visitor Comments